Avidyne Homepage
Forum Home Forum Home > Avidyne General > IFD 5 Series & IFD 4 Series Touch Screen GPS/NAV/COM
  New Posts New Posts RSS Feed - Strange IFD440+KFC200 behavior
  FAQ FAQ  Forum Search   Register Register  Login Login

Strange IFD440+KFC200 behavior

 Post Reply Post Reply
Author
Message
tommy View Drop Down
Newbie
Newbie


Joined: 17 May 2018
Location: Australia
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote tommy Quote  Post ReplyReply Direct Link To This Post Topic: Strange IFD440+KFC200 behavior
    Posted: 29 May 2018 at 8:11am
Hi everyone! I am hoping to dig someone's brain on an interesting problem (for me at least ๐Ÿ˜ƒ)!


Recently I had fitted an IFD440 and APX340 coupled with KFC200 + KI525 (HSI) + KI256 (with FD)

After some initial testing of the unit, we noticed that the A/P always track 30 degrees to the left the course set. 

We tried the following scenarios


IFD setting     A/P mode

____________________


VLOC (green)  NAV/CPLD

GPS                   NAV/CPLD

RNAV                APPR / CPLD


The AP will always turn and hold the plane 30-degree left of the track. This is despite the CDI course set correctly and the deviation is - correctly - slowly moving to the right. The FD is definitely commanding. The CDI course deviation is accurate. The HDG mode is working fine. I never had tried flying any of the above mentioned mode as I am VFR only so I don't know if they are working properly before. Me bad!


My shop bench tested the HSI and no faults were found. Wonder what other potential causes for this?


Thanks guys

Back to Top
Gring View Drop Down
Senior Member
Senior Member


Joined: 30 Dec 2011
Location: Kingston, NY
Status: Offline
Points: 534
Post Options Post Options   Thanks (0) Thanks(0)   Quote Gring Quote  Post ReplyReply Direct Link To This Post Posted: 29 May 2018 at 10:00am
I have this setup in my Bonanza (IFD540).

A couple of thoughts:

1) In the maintenance screens, check to see that when the CDI needle is set to 150 deg the IFD says it is 150deg. If not, follow the instructions to sync the two then check every 30 degrees. The two should match.

2) Once the KFC200 aligns with the course, it switches mode and only follows the deviation of the CDI, not the actual heading direction. You may have a KFC200 problem.
Back to Top
tommy View Drop Down
Newbie
Newbie


Joined: 17 May 2018
Location: Australia
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote tommy Quote  Post ReplyReply Direct Link To This Post Posted: 29 May 2018 at 6:19pm
Thanks Gring!

Which "section" or page should I be of the maintenance screen to do that?
Do you have the manual or a link to it on how to sync the two?

Thanks, Gring! Really appreciate it

Back to Top
tommy View Drop Down
Newbie
Newbie


Joined: 17 May 2018
Location: Australia
Status: Offline
Points: 7
Post Options Post Options   Thanks (0) Thanks(0)   Quote tommy Quote  Post ReplyReply Direct Link To This Post Posted: 30 May 2018 at 9:12am
Actually, I loaded into the the maintenance page and saw the sync page. They are already in sync. :( 
Looks like it's not going to be a cheap fix then. 

Come to think of it, it does appear that my KFC 200 isn't really following the deviation of the CDI at all. It just wants to track 30 degree to the left of the CDI course. The Course selector on my HSI is acting like a heading bug. 

:( 

Back to Top
Gring View Drop Down
Senior Member
Senior Member


Joined: 30 Dec 2011
Location: Kingston, NY
Status: Offline
Points: 534
Post Options Post Options   Thanks (0) Thanks(0)   Quote Gring Quote  Post ReplyReply Direct Link To This Post Posted: 30 May 2018 at 9:26am
To verify, try tracking a VOR inbound and see if it continues to show the same behavior.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.