Avidyne Homepage
Forum Home Forum Home > Avidyne General > IFD 5 Series & IFD 4 Series Touch Screen GPS/NAV/COM
  New Posts New Posts RSS Feed - SDK "Getting Started" Help
  FAQ FAQ  Forum Search   Register Register  Login Login

SDK "Getting Started" Help

 Post Reply Post Reply
Author
Message
vancinad View Drop Down
Newbie
Newbie


Joined: 23 Sep 2018
Location: USA
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote vancinad Quote  Post ReplyReply Direct Link To This Post Topic: SDK "Getting Started" Help
    Posted: 31 Aug 2019 at 11:54am
I'm working on integrating my EFB of choice, Avare, with the IFD series. My goal is to be able to exchange flight plan information between the two.

I have had limited success with the example apps in the SDK. I've gotten the VHF Status app to work, but I'm getting errors building others. (Specifically MSCOREE.LIB missing.)

I'm using Visual Studio 2017 Community. Is that the right tool? Any things I need to add or configs I need to tweak?
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 873
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: 01 Sep 2019 at 6:48pm
It was originally complied using VS2005.  I just migrated WiFi Tier2 App to 2017 Community and it worked with no modifications.  Which projects are giving you difficulty?
Steve Lindsley
Avidyne Engineering
Back to Top
vancinad View Drop Down
Newbie
Newbie


Joined: 23 Sep 2018
Location: USA
Status: Offline
Points: 15
Post Options Post Options   Thanks (0) Thanks(0)   Quote vancinad Quote  Post ReplyReply Direct Link To This Post Posted: 06 Sep 2019 at 9:14am
Hi Steve. I was having trouble almost across the board with a missing MSCOREE.LIB. (I was able to get the VHFStatus example working, so the problem is not universal, but it is broad.)

I think I may have told VS Studio to retarget the solution for Windows 10, so I'm downloading the Win 8.1 SDK and will try again.

If you have any immediate suggestions please pass them along. Otherwise I'll try again after I've got SDK 8.1 installed and see if that solves the problem.

Thanks!
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.