Avidyne Homepage
Forum Home Forum Home > Avidyne General > IFD 5 Series & IFD 4 Series Touch Screen GPS/NAV/COM
  New Posts New Posts RSS Feed - Screen aberrations on IFD 540
  FAQ FAQ  Forum Search   Register Register  Login Login

Screen aberrations on IFD 540

 Post Reply Post Reply
Author
Message
jeffcb View Drop Down
Newbie
Newbie


Joined: 05 Apr 2018
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote jeffcb Quote  Post ReplyReply Direct Link To This Post Topic: Screen aberrations on IFD 540
    Posted: 15 Feb 2021 at 4:17am
Has anyone else seen this problem?:
When I start my IFD 540, it has taken to showing the areas of the screen which should be black as fluorescent green, with wavy darker lines moving across it. It is like green snow on an old TV.
All data is still present, and unit appears to function normally.
So far, restarting it multiple times eventually seems to overcome the problem, with the black background areas reappearing. However, in general it is taking more and more restarts to before the display corrects itself.
JPI is showing 12.1 volts as it starts.
Looks like something serious, so have not flown with it.
Please comment as appropriate.
Regards
Jeff Bell


Jeff
Back to Top
oskrypuch View Drop Down
Senior Member
Senior Member


Joined: 09 Nov 2012
Location: CYFD
Status: Offline
Points: 2792
Post Options Post Options   Thanks (0) Thanks(0)   Quote oskrypuch Quote  Post ReplyReply Direct Link To This Post Posted: 15 Feb 2021 at 1:57pm
Why is the JPI showing ONLY 12.1v? If that is with the engine running, that is not normal.

If the low voltage and screen issue co-incide, you have found the cause, and need to check out your alternator/regulator/battery.

* Orest


Edited by oskrypuch - 15 Feb 2021 at 1:59pm
Back to Top
jeffcb View Drop Down
Newbie
Newbie


Joined: 05 Apr 2018
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote jeffcb Quote  Post ReplyReply Direct Link To This Post Posted: 15 Feb 2021 at 7:10pm
Thanks for the reply.
Voltage is engine stopped, battery on charger.
Have started it in this configuration hundreds of times while practicing.
If it is low voltage, then why would it correct itself after numerous restarts?
Regards
Jeff


Jeff
Back to Top
jeffcb View Drop Down
Newbie
Newbie


Joined: 05 Apr 2018
Status: Offline
Points: 28
Post Options Post Options   Thanks (0) Thanks(0)   Quote jeffcb Quote  Post ReplyReply Direct Link To This Post Posted: 09 Jun 2021 at 4:49am
Avidyne have been kind enough to repair the Graphics Processing problem in my IFD 540 under warranty, although it is 3 years old.
Thank you.
However I am afraid I don't have a kind word to say about Fedex, with whom I tried to ship the Avidyne from Australia to USA.
Regards
Jeff
Jeff
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.055 seconds.