Avidyne Homepage
Forum Home Forum Home > Avidyne General > EXP5000 Entegra PFD
  New Posts New Posts RSS Feed - EXP5000 knob not working...
  FAQ FAQ  Forum Search   Register Register  Login Login

EXP5000 knob not working...

 Post Reply Post Reply
Author
Message
TomC View Drop Down
Newbie
Newbie


Joined: 12 Dec 2013
Location: San Antonio
Status: Offline
Points: 2
Post Options Post Options   Thanks (0) Thanks(0)   Quote TomC Quote  Post ReplyReply Direct Link To This Post Topic: EXP5000 knob not working...
    Posted: 12 Dec 2013 at 2:26pm
I have an EXP5000 in a 2007 Cirrus. The knob on the right side bottom that changes values for the Hdg Bug, Alt Bug, VSI bug and Baro Set is no longer working. Twisting it in any of those modes does nothing.

The only thing that works with that knob is that pressing it will sync the heading bug with the current heading...

Any thoughts? Easy to repair?!

Thanks,
Tom
Back to Top
AviJake View Drop Down
Admin Group
Admin Group


Joined: 26 Mar 2009
Location: Lincoln MA
Status: Offline
Points: 2815
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviJake Quote  Post ReplyReply Direct Link To This Post Posted: 12 Dec 2013 at 8:02pm
Hi Tom,

I'll make sure Customer Support and the Avidyne Service Center are aware.  Do they have your contact info and pertinent PFD details?

If not, I suggest sending them directly to Jared Butson (jbutson@avidyne.com).   In any case, I gave them a heads up.
Steve Jacobson
sjacobson@avidyne.com
Back to Top
nestor View Drop Down
Newbie
Newbie


Joined: 20 Jul 2021
Location: Lyon, France
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote nestor Quote  Post ReplyReply Direct Link To This Post Posted: 20 Jul 2021 at 1:05pm
Hi,
We have exactly the same issue in our club’s SR20’s EXP5000 PFD: right knob not working, identical symptoms. 
Any fix ?
Thanks. 
Nestor 
Back to Top
starlord View Drop Down
Newbie
Newbie


Joined: 16 Sep 2021
Location: Germany
Status: Offline
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote starlord Quote  Post ReplyReply Direct Link To This Post Posted: Yesterday at 9:16am
This problem seems not to be an isolated one. I have the same issue since a few month now on a 2005 SR22 EX5000 PFD. From time to time it works again until next flight.
PFD already changed in 2018 due to faulty backlighting.
Are there any suggestions?
Back to Top
AviSteve View Drop Down
Admin Group
Admin Group
Avatar

Joined: 12 Feb 2018
Location: Melbourne, FL
Status: Offline
Points: 1542
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviSteve Quote  Post ReplyReply Direct Link To This Post Posted: Yesterday at 10:04am
It sounds like a problem with the encoder, but it would be best to call tech support with this one.
Steve Lindsley
Avidyne Engineering
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.047 seconds.