Avidyne Homepage
Forum Home Forum Home > Avidyne General > TWX670 Tactical Weather Detection System
  New Posts New Posts RSS Feed - Error Messages
  FAQ FAQ  Forum Search   Register Register  Login Login

Error Messages

 Post Reply Post Reply
Author
Message
firebreather View Drop Down
Newbie
Newbie


Joined: 27 Dec 2012
Location: Atlanta, GA
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote firebreather Quote  Post ReplyReply Direct Link To This Post Topic: Error Messages
    Posted: 06 Jan 2013 at 12:14pm
I am flying a Columbia 400 with a recent install of the TWX670 to an Avidyne Integra.  The TWX670 stays in Error status during climbs.  A message comes up "Lightning Noise Senser Present".  After settling in on a cruise setting, the TWX670 appears to fall into the Strike mode.
 
The first flight showed false strikes 20-60nm at 3:00 and 150-200nm at 6:00.  I cycled the strobes and this seemed to eliminate the false strikes.  Also the voice warning was barely audible, but I could hear it in the background.  Is there a way to turn up the volume?
 
About 15 hrs and 5 flights later the Error came up on the MFD and there was some slight background noise during cruise.  I noticed it because the noise caused the XM radio to mute.  After turning off the Air Conditioning, the background noise went away and the TWX670 went into Strike mode.
 
Does anybody have any suggestions for eliminating the Error status of the system?
 
ps. The manual needs serious editing.  The references to pages are incorrect and there is no reference to the Integra display.
Back to Top
AviJake View Drop Down
Admin Group
Admin Group


Joined: 26 Mar 2009
Location: Lincoln MA
Status: Offline
Points: 2815
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviJake Quote  Post ReplyReply Direct Link To This Post Posted: 19 Jan 2013 at 9:28am
Just saw this post.....checking with our "Mr. TWX" and will post a response as soon as I hear back.
Steve Jacobson
sjacobson@avidyne.com
Back to Top
AviJake View Drop Down
Admin Group
Admin Group


Joined: 26 Mar 2009
Location: Lincoln MA
Status: Offline
Points: 2815
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviJake Quote  Post ReplyReply Direct Link To This Post Posted: 26 Jan 2013 at 3:59pm
From Avidyne Tech Support who have seen similar issues before:  Hope this helps:

"So in the Columbia Aircraft there are a few issues that need to be accomplished.  The processor needs to be relocated as far aft as possible.  I have always had to mount it next to the ELT, and then relocate the #2 WAAS antenna about 12 inches aft of its present position.  The WAAS antenna is mounted on a bracket inside the tail about 3 inches aft of the ELT, and close to where the TWX670 processor will be mounted.  If the antenna is not relocated the TWX670 will interfere with the GPS signal and cause about 20% satellite reception.  Also the TWX670 requires the ECS antenna cable, and must be routed in the overhead(with no other wiring in the run).  The antenna needs to have MU Metal installed on the inside of the aircraft attached to the doubler plate.  Noise filters must be installed on alternators 1 and 2, however if the aircraft has the EVADE System installed you can't install a noise filter on the number 3 alternator(which is used only for the EVADE System).  The drop in voltage will cause the EVADE system to fail self-test, and will not function.  There is no way to completely Eliminate noise if the EVADE system is installed and active, you will typically receive strikes at the 10 o-clock position about 150 miles out (however it will not cause the TWX to fail).  A 1/2 inch bonding strap will also need to be installed from the TWX670 Processor to the negative terminal of the aircraft battery.  Hope this helps."

Steve Jacobson
sjacobson@avidyne.com
Back to Top
firebreather View Drop Down
Newbie
Newbie


Joined: 27 Dec 2012
Location: Atlanta, GA
Status: Offline
Points: 4
Post Options Post Options   Thanks (0) Thanks(0)   Quote firebreather Quote  Post ReplyReply Direct Link To This Post Posted: 06 Feb 2013 at 11:23am
Do you have contact information for tech support?
Back to Top
AviJake View Drop Down
Admin Group
Admin Group


Joined: 26 Mar 2009
Location: Lincoln MA
Status: Offline
Points: 2815
Post Options Post Options   Thanks (0) Thanks(0)   Quote AviJake Quote  Post ReplyReply Direct Link To This Post Posted: 06 Feb 2013 at 12:27pm
Couple of methods:

US Toll Free:  888 723 7592
Email:  techsupport@avidyne.com

International #:   http://www.avidyne.com/contact/intphones.asp


Steve Jacobson
sjacobson@avidyne.com
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 12.01
Copyright ©2001-2018 Web Wiz Ltd.

This page was generated in 0.066 seconds.